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Data on Demand

1  About Data on Demand (DoD)
Data on Demand (DoD) Version 1.02 provides options to request waveform data by 
channel and time period from remote Cygnus or Janus comms devices, for transmission 
to a specified NAQS Server. The comms device collects data in ringbuffers at the 
remote site and will respond to retransmission requests, but continuous real-time data 
are not sent to the central site for channels set to Demand.

Using DoD you can select data of interest by time period from the remote ringbuffer 
for channels set to Demand. These requests may include future data. The selected data 
are then transmitted to the central site NAQS Server. You can use DoD manually via 
the graphical user interface (GUI) or the command line interface (CLI), or automati-
cally by invoking the CLI via scripts in conjunction with user-provided event detection 
software.

See also the NaqsServer and Nanometrics UI user guides.

2  Installing DoD

2.1   Dependencies

DoD Version 1.02 requires CommsController Version 5.80.75 or higher, NaqsServer 
Version 1.90.00 or higher, and J2RE 1.42_0x or higher.

2.2   Install DoD

On Windows:

1. If the directories c:\nmx\bin and c:\nmx\user do not already exist on the 
computer, create them.

2. From either a command prompt or Windows Explorer, open the installation CD 
directory Win32\DataOnDemand\version number.

3. Copy all of the files from the bin directory into the c:\nmx\bin directory.

4. Check the system path, and add the directory c:\nmx\bin if it is not already 
included.
Data on Demand Version 1.02
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Data on Demand
5. Optionally for the DoD GUI, create a shortcut on the desktop and edit the startup 
parameters (see Section 5.1 on page 5 for startup options). For example, to use a 
specific settings file rather than the default:
a) Create a shortcut on the desktop to the file dod.bat.
b) Right click on the shortcut icon and choose Edit.
c) Edit the startup parameters to use a specific settings file rather than the default:

java -ms5m -cp c:\nmx\bin\DataOnDemand.jar
ca.nanometrics.dataondemand.DataOnDemandGUI settingsFile

The optional parameter settingsFile specifies a settings file to load on startup 
(see also Section 5.3, “Save settings for DoD GUI sessions,” on page 6).

On Solaris or Linux:

1. If the directories /nmx/bin and /nmx/user do not already exist on the compu-
ter, create them.

2. Open the installation CD directory OS/DataOnDemand/version number.

3. Copy all of the files from the bin directory into the /nmx/bin directory.

3  Setting instrument channels to Demand
Go to the Nanometrics UI Configuration > Ringbuffer page to select time-series 
data channels to send only on Demand (for example, Figure 3-1; see also the Nan-
ometrics UI manual).

Figure 3-1  Set instrument data channels to Demand in the Nanometrics UI
Data on Demand Version 1.02
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Data on Demand
4  Using DoD via the CLI
DoD CLI options typically would be used in conjunction with automatic event detec-
tion software via scripts, to ensure that event data are retrieved from the instrument 
ringbuffer before being overwritten. You may also use the CLI manually.

Requests typically would be defined either with a text input file created via scripts or 
with binary scheduled request files (*.ser files) saved from a previous DoD session. 
DoD CLI can also use as an input file an XML settings file either saved from a DoD 
GUI session or edited manually.

DoD can include future data in a request. For example, to collect 5 minutes of event 
data starting 1 minute before an event, with automatic detection software that recog-
nizes the event within 30 seconds, the DoD request will include 1.5 minutes of historic 
data and 3.5 minutes of future data. For future-dated requests DoD will wait until the 
end time has passed before sending the request.

4.1   Start a DoD CLI session

Notes:
1) If DoD exits abnormally (for example, if you terminate the session with 

Ctrl-C) there may be a lock file left in nmx\scheduleItems which will 
prevent a subsequent session from working. Delete the file 
nmx\scheduleitems\DataOnDemandSched.run before starting 
a new session of DoD.

2) The start and end times of the data actually sent for a requested time 
period are determined by packet boundaries and may vary by several 
seconds on either side of a start or end time. For example, a request 
for 5 minutes of data starting at 18:00:00 hours may return data for the 
period starting at 17:59:57 and ending at 18:04:55.

Table 4-1 lists DOD CLI options. Start DoD CLI in the working directory (typically 
nmx\user).

Table 4-1  DoD command line options

To run this option... Use this command

Invoke DoD, connect to the local NaqsServer at port 
28000, and look for any existing requests not yet sent 
(in c:\scheduleitems\*.ser files). DoD exits if 
and when all requests are sent.

dod cli

Invoke DoD, connect to the NaqsServer at the 
naqsaddress and port specified, and look for any 
existing requests not yet sent (in 
c:\scheduleitems\*.ser files). DoD exits if and 
when all requests are sent.

dod cli naqsaddress:port

Invoke DoD, connect to the local NaqsServer at port 
28000, and look for any existing requests not yet sent 
(in c:\scheduleitems\*.ser files) and requests 
specified in inputfile. DoD exits if and when all 
requests are sent.

dod cli inputfile
Data on Demand Version 1.02
User Guide
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Data on Demand
4.1.1    Format for the optional input file

DoD CLI optionally may use an input file. The input file can be either a text file with 
a specified format, or an XML settings file.

Each row of a text input file must include these 5 fields only, separated by white space:
stationName channelName startTime duration maxTime

where startTime is in UTC, and duration and maxTime are in seconds (maxTime is the 
maximum time that Naqs will store the request in case there are retransmit requests 
within the DoDRequest). For example:

STN01 BBN 2005-03-22-19:25:00 330 300
STN01 BBZ 2005-03-22-19:25:00 330 300

An XML settings file must either have been saved from the DoD GUI (Section 5.3.1 
on page 6) or have the same structure as a GUI settings file if you have created the file 
manually.

4.2   Exit a DoD CLI session

A DoD CLI session will exit automatically under all conditions:
For normal operation, DoD will exit once all requests have been sent.
For cases where there is a problem (for example, a problem connecting to 
NaqsServer) or an absence of request information (for example, no scheduled 
items, or where specified channels are not found in the NaqsServer channel list), 
DoD will exit as appropriate (for example, after a certain number of attempts have 
failed).

You can also terminate a DoD CLI session with Ctrl-C before it exits automatically. 
(DoD will save all pending requests to disk as *.ser files. The pending requests are 
available for the next session of either the DoD CLI or DoD GUI.) However, terminat-
ing DoD may leave a lock file in nmx\scheduleItems which will prevent a subse-
quent DoD session from running properly.

If this occurs, delete the file nmx\scheduleItems\DataOnDemand-
Sched.run before starting a new session of either the DoD CLI or DoD GUI.

5  Using DoD via the GUI
Use the DoD GUI to specify a NaqsServer for connection, a list of data channels, the 
time period for requested data, and the maximum time to wait for retransmission 
requests. You can edit the settings for use in the current session, and you can save the 

Invoke DoD, connect to the NaqsServer at 
naqsaddress and port specified, and look for any 
existing requests not yet sent (in 
c:\scheduleitems\*.ser files) and requests 
specified in inputfile. DoD exits if and when all 
requests are sent.

dod cli inputfile naqsaddress:port

Table 4-1  DoD command line options (Continued)

To run this option... Use this command
Data on Demand Version 1.02
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Data on Demand
settings as an XML file for future use. Requests are sent to the scheduler once you click 
Send.

5.1   Start a DoD GUI session

Note If DoD exits abnormally there may be a lock file left in nmx\sched-
uleItems which will prevent a subsequent session from working. Delete 
the file nmx\scheduleitems\DataOnDemandSched.run before start-
ing a new session of DoD.

You can start a DoD GUI session from a shortcut or from the command line, and with 
either default settings or saved settings.

If you are not using a shortcut, open a command prompt and then start DoD from 
the working directory with a command option as listed in Table 5-1.

Table 5-1  DoD GUI startup options

To start the GUI with these options... Enter this command

Invoke the GUI with default settings (NaqsServer at address 
localhost on Datastream service port 28000, current date and time, 
duration 0 seconds, maximum wait time 3600 seconds, channels as 
listed in Naqs).

dod

Invoke the GUI and apply the settings saved in the settingsFile. 
(Requests are not sent to the scheduler until you click Send in the 
GUI.)

dod settingsFile

Invoke the GUI and connect to the NaqsServer address and port 
specified (the remaining settings are defaults).

dod naqsaddress:port

Figure 5-1  Data on Demand window
Data on Demand Version 1.02
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Data on Demand
5.2   Exit a DoD GUI session

Note Unsaved changes to GUI settings are discarded on exiting a DoD GUI 
session. See Section 5.3 for information on saving the GUI settings.

To exit a DoD GUI session, either click the Exit button at the bottom of the win-
dow, choose Exit from the File menu, or click the window close control.

5.2.1    Manage pending requests on exit

DoD provides three options for managing existing requests when you choose to exit a 
DoD GUI session (Figure 5-2).

To keep the requests on disk for use in a subsequent session, click Yes.

To remove the requests from disk, click No.

To keep the requests on disk and return to DoD without exiting, click Cancel.

5.3   Save settings for DoD GUI sessions

Caution DoD does not provide a warning if you are about to overwrite an exist-
ing file with Save or Save As. Use caution when selecting a filename 
from the file browser.

You can save DoD settings from the GUI to a settings file as XML. You can start new 
DoD GUI sessions with saved settings, and load different settings during a current DoD 
GUI session. DoD CLI can also use a saved GUI settings file as an input file (Section 
5.1 on page 5).

5.3.1    Save basic settings to an XML file

You are not prompted to save changes to GUI settings when you exit DoD. You can 
save basic settings at any time during a DoD session, either to a new file, or to the cur-
rent file if you want to replace the current settings.

To save a new settings file:
a) From the File menu, choose Save As.
b) In the browser window, select the path and type in a settings file name.
c) Click Save. (To exit without saving the changes, click Cancel.)

To overwrite settings in the current settings file with the new settings:

From the File menu, choose Save.

Figure 5-2  Options for managing pending requests on exit
Data on Demand Version 1.02
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5.3.2    Load saved settings

Note On startup with either default or saved settings, DoD will look for existing 
requests as *.ser files and send them as scheduled, but requests 
defined in the GUI are not scheduled until you click Send.

DoD will connect automatically to the specified NaqsServer and restore the saved set-
tings to the GUI when it loads a settings file.

There are two ways to load DoD GUI settings that you have saved:

Specify the name of the settings file when you start DoD, either predefined as part 
of the shortcut target or as a command-line argument:
dod settingsFile

After you have started DoD, choose File > Open and browse for a settings file.

5.4   Edit settings for a DoD GUI session

You can edit settings in the GUI for the current session. If you then save the settings 
(Section 5.3) you can load and edit them in a subsequent session, and you can also edit 
the XML file directly.

5.4.1    Connect to a NaqsServer

The Set NaqsServer Parameters section at the top of the DoD window provides fields 
for you to specify the Naqs server host address and the port for the Naqs Datastream 
service.

If you specified a settings file on startup, DoD will attempt to connect to the host 
address and port specified in the file. Otherwise, it will attempt to connect to the default 
settings (Host: localhost and Port: 28000).

If you wish to specify different Naqs connection settings:

1. Type in the Naqs server host name or IP address, and the port of the Datastream 
service if it is different for this Naqs server (the Datastream port is defined in the 
Naqs.ini file; the default is 28000).

2. Press Enter or click in another field in the DoD window to connect to the Naqs 
server.

The connection status to the Naqs server is indicated in the status bar at the bottom of 
the window (either Connected or Not Connected). Once DoD has connected to Naqs, 
it receives a channel list from Naqs and can send DoD requests to Naqs. An error mes-
sage will be displayed if the Naqs that DoD is connected to does not have one or more 
of the channels listed in the settings file.

5.4.2    Set the time interval

Note  The start and end times of the data actually sent for a requested time 
period are determined by packet boundaries. For example, a request for 
5 minutes of data starting at 18:00:00 hours may return data starting at 
17:59:57 and ending at 18:04:55.
Data on Demand Version 1.02
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Data on Demand
You can set the time period for requested data as either a duration from a specific start 
time or as the most recent period. For future-dated requests DoD will wait until the end 
time has passed before sending the request, therefore take into account the instrument 
channel ringbuffer size when defining the time period for these requests.

To set an explicit time interval, in the top row enter a start date and start time, a 
duration, and then select units for the duration from the drop down list.
These options are only available if the Most Recent check box is unselected (Fig-
ure 5-3).

To specify requested data by the most recent time period, select the Most Recent 
check box, enter the duration in the text box next to it, and then select units for the 
duration from the drop down list.
Options for most recent duration are only available if the Most Recent check box 
is selected (Figure 5-4).

5.4.3    Set the maximum wait time

You can set the maximum wait time for Naqs to store a DoD request. If a DoD request 
is sent to a comms device, the request will remain in Naqs for as long as specified in 
the Maximum Wait Time setting, or until all the data requested has been received, or 
until Naqs is restarted. When the wait time interval times out, the request expires and 
Naqs removes the request from the request list.

If you submit a DoD request when the link to the comms device is down, then the 
request will continue to be managed by Naqs but the comms device will never receive 
the request. As a result the requested data will never arrive, even after the link to the 
comms device is restored. If this occurs, you may resubmit the data request.

Naqs always accepts any incoming data, even after the request expires. For example, if 
Naqs is restarted, it will accept the data requested before the restart, but Naqs will no 
longer request retransmission of missing data.

To set the maximum wait time, enter a Maximum Wait Time duration and then 
select the duration units from the drop down list.

Figure 5-3  Set an explicit time interval for requested data

Figure 5-4  Request the most recent data
Data on Demand Version 1.02
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5.4.4    Select data channels

You can select channels using options in the Channels table (Figure 5-5). If a settings 
file has been loaded, the channel list is from the saved settings. Otherwise, the list of 
channels is obtained from NaqsServer. Only data channels will appear in the list.

To select  or deselect  a channel, click in the Get Data checkbox for that chan-
nel.

To sort the table (for example, by instrument name), click on the corresponding 
column header.

5.4.5    Restore Naqs channels to the channel table

If the channel list is changed in Naqs, you may wish to restore the list of available chan-
nels in DoD. Restoring Naqs channels will clear the table and then list the data channels 
from Naqs. A log message will be generated if a request is made on a non-existent 
channel. (You can also delete unavailable channels from the list manually; see Section 
5.4.6.)

To restore the list of currently available channels:

1. Choose File > Restore Naqs Channels.

2. If you wish to save the new channel list, save the DoD settings to the current file or 
to a new settings file (see Section 5.3.1 on page 6).

5.4.6    Delete channels from the channel table

To remove a channel from the list of available channels:

1. Click in the table row to select the channel, and then either click Delete in the DoD 
window or press the Delete key on the keyboard.

2. If you wish to save the new channel list, save the DoD settings to the current file or 
to a new settings file (see Section 5.3.1 on page 6).

If all channels are deleted from the channel table and Naqs reconnects (for example, 
after a restart), all of the currently available channels will reappear in the channel table.

5.5   Send a DoD request
To send a DoD request, click Send.
This will send the DoD request to Naqs for channels selected to Get Data, which 
will send it on to the instrument as well as to the ringbuffer DoD request manage-

Figure 5-5  Table of available channels
Data on Demand Version 1.02
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Data on Demand
ment system. Requested data will then be written to the ringbuffers for the selected 
channels.

If you choose to exit DoD before scheduled requests have been processed, you may 
either discard the pending requests or save them for a subsequent DoD session (see also 
Section 5.2.1 on page 6).

6  Backing up the retrieved data from Naqs
Ensure that you back up stored data from the Naqs ringbuffers for DoD channels before 
they are overwritten by subsequent requests. Naqs ringbuffers store data by sequence 
number, therefore, older retrieved data may be overwritten even if the requested seg-
ments of data are small relative to the configured ringbuffer size. For example, a ring-
buffer with the capacity to store 1 week of data will not store data from two requests 
that are more than 1 week apart.

You can save data from the Naqs ringbuffers either by copying the file to another 
location, or by using Atlas to retrieve the data to save to a SEED file or an Oracle 
database.

7  Viewing the operation logs
DoD generates log messages that trace the operation of the program. It displays these 
messages in the terminal window and writes them to the DoD log file. The level of 
detail (the verbosity) of the information to be displayed is the same as the NaqsServer 
setting (set in the [ NaqsLog ] section of the Naqs.ini configuration file).

To view the log for a particular date, open the file DoD_date.log in a text editor. 
The log file location is the same as that of the NaqsServer log file (set in the 
[ NaqsLog ] section of the Naqs.ini configuration file).

8  Viewing the version information
To view the version and copyright information for this release of DoD, choose 
Help > About Data on Demand.
Data on Demand Version 1.02
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