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Chapter 1 Getting Started

NaqsView provides an intuitive interface to view realtime state-of-health (SOH) data 
from NaqsServer, and to send mass centring and basic calibration commands to 
NaqsServer. NaqsView can also show historical SOH data via visual cues and with 
time-SOH history plots.

NaqsView provides 6 predefined SOH viewers, and the option to create custom view-
ers:

Instrument Voltage and Temperature
Environmental State of Health
Satellite Modem State of Health
RM4 Voltage and Temperature
Instrument GPS
Mass Position and Centering
option to create custom SOH viewers based on any available data bundle type.

NaqsView communicates with NaqsServer and DataServer via TCP/IP socket, so it can 
be run either on the NaqsServer machine or on any machine that has an Internet con-
nection to the NaqsServer. An active DataServer is required to generate history plots.

1.1  Installing NaqsView
NaqsView is part of the Naqs Client package, included on the Nanometrics software 
installation CD.

1.1.1   Install NaqsView

On Windows:

1. If the directories c:\nmx\bin and c:\nmx\user do not already exist on the 
computer, create them.

2. From either a command prompt or Windows Explorer, open the installation CD 
directory Win32\NaqsClient\version number

3. Copy all files from the bin directory into the c:\nmx\bin directory.

4. Check the system path, and add the directory c:\nmx\bin if it is not already 
included.
NaqsView Version 2.10
User Guide

14909R2
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Chapter 1: Getting Started
5. Optionally, create a shortcut (Section 1.1.2).

On Solaris or Linux:

See the acquisition workstation installation instructions.

1.1.2   Create a shortcut

The optional parameter settingsFile specifies a settings file to load on startup (see also 
Section 1.4, “Saving NaqsView settings,” on page 5).

On Windows:

1. Create a shortcut on the desktop to the file naqsview.bat.

2. Right click on the shortcut icon and choose Edit.

3. Edit the startup parameters to use a specific settings file rather than the default:
javaw -cp c:\nmx\bin\NaqsView.jar NaqsView settingsFile

On Solaris or Linux:

See the acquisition workstation installation instructions.

1.2  Starting NaqsView
NaqsView runs in the Java runtime environment version 1.4.2_0x or later.

You can start a NaqsView session from a shortcut or from the command line.

1.2.1   Start NaqsView
Start NaqsView with the desktop shortcut, if you have defined one.

If you are not using a shortcut:

On Windows:

1. Open a command prompt.

2. Change directories to your working directory. Unless you have defined a different 
working directory, this will be nmx\user.

3. Start NaqsView from the command line:
NaqsView settingsFile
where the optional parameter settingsFile specifies a settings file to load on startup 
(see also Section 1.4, “Saving NaqsView settings,” on page 5). If no settings file is 
specified, or if you wish to change connection settings for the current session, you 
will need to enter parameters for this session.

On Solaris:

Open a command window and type in naqsview.
A warning will be displayed indicating that the settings file does not exist if:
NaqsView Version 2.10
User Guide2 14909R2

2004-09-09



Chapter 1: Getting Started
• This is the first time you have started NaqsView, and the initial settings file 
naqsview.ini does not yet exist.

To prevent this warning from being displayed next time you start NaqsView, 
save the settings to /nmx/user/naqsview.ini before closing Naqs-
View.

• You have changed the settings file name or location to a new path/settingsFile 
since the last session.

To prevent this warning, edit the file naqsview in /nmx/bin. Change 
the text “naqsview.ini” to the name of the new settings file. Include the path 
if the new settings file is not in the working directory.

1.2.2   Connect to NaqsServer
1. Specify connection settings to access data for this session, using the options in the 

main NaqsView window (Figure 1-1). (If you have specified a settings file, the set-
tings saved in that file will load automatically.)
a) In the panel labelled Set NaqsServer Parameters, type in values for the 

NaqsServer Connection Manager:
IP address or Host name
Port number

(These values are defined in the Naqs.ini file; see also the NaqsServer doc-
umentation.)

b) In the panel labelled Set DataServer Parameters, type in values for the 
DataServer:

IP address or Host name
Port number
User Name
Password

(These values are defined in the [ Users ] section of the dataserver.ini 
file; see also the DataServer documentation.) If historical SOH data are not 
required, these fields may be left blank.

Note If you are running multiple NaqsServers that use the same station param-
eters for different networks, ensure you are obtaining historical data from 
the correct source: Make sure the DataServer is connected to the speci-
fied NaqsServer.
NaqsView Version 2.10
User Guide

14909R2
2004-09-09 3



Chapter 1: Getting Started
2. Connect to NaqsServer:
a) Click to select the Connect check box.
b) If the NaqsServer Datastream service has been configured to operate in call-

back mode, select the Callback Socket check box.
c) Click Apply to set the connection parameters.
When you click Apply, NaqsView will connect to NaqsServer and will report any 
connection errors in the log. The connection status is shown in the right-hand field 
of the status bar (Figure 1-2).

Note You can edit the connection parameters at any time; click Apply to set the 
new parameters. The viewers will update, but any open history plots will 
not.

1.3  Using the NaqsView log
The log shows messages related to the operation of NaqsView since NaqsView was 
started. You can use this information to monitor operation. (For example to determine 
if data are arriving, and to diagnose connection problems.) The log normally operates 
in a scrolling mode so that new messages are always visible at the bottom of the log 
window. The log options are available from the Log menu (Figure 1-2). For a descrip-
tion of these options, see Section A.1.3 on page 24.

Figure 1-1  The main Naqsview window

Figure 1-2  Example NaqsView session

Connection status
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User Guide4 14909R2

2004-09-09



Chapter 1: Getting Started
1.4  Saving NaqsView settings
You can save all NaqsView settings—such as connection parameters, channel selec-
tions, history plot settings, and the size and placement of windows—to a settings file. 
You can save these settings at any time during a NaqsView session either to a new set-
tings file, or to the current settings file if you want to replace the current settings.

You can start new NaqsView sessions with saved settings, or load different settings 
during a running session of NaqsView.

Note The settings file is a binary format and cannot be edited manually.

1.4.1   Save NaqsView settings to a file

To save a new settings file:

1. From the File menu, choose Save As....

2. In the browser window, choose the path and type in a file name.

3. Click Save. (To exit without saving the changes, click Cancel.)

To overwrite settings in the current settings file with the new settings:

From the File menu, choose Save.

1.4.2   Load a saved settings file

NaqsView will automatically connect to NaqsServer and restore all window sizes and 
settings when it loads a settings file. There are two ways to load NaqsView settings that 
you have saved:

Specify the name of the settings file when you start NaqsView, either predefined as 
part of the shortcut target or as a command-line argument:
NaqsView settingsFile

Load the settings using the Open option of the NaqsView File menu:
File > Open... > filename

1.4.3   Rename a settings file on Solaris or Linux
To change the name of the settings file, edit the file /nmx/bin/naqsview. 
Replace the current settings file name (initially, naqsview.ini) with the new 
settings file name.

1.5  Opening the Help file
Note You must have a PDF reader installed to open the help file from Naqs-

View.

To open the help file, from the Help menu choose Help topics.
NaqsView Version 2.10
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1.5.1   Define the location of the PDF executable

The first time you try to open the help file, a dialog box may prompt for the path to the 
PDF reader executable. To set the initial path:

On Windows:

1. Right click on either the shortcut on the desktop or the Programs menu item for the 
PDF reader.

2. From the pop-up menu, choose Properties.
The Target text field shows the full path to the executable.

On Solaris or Linux:

If the PDF reader is in the path, type the name of the executable (typically 
acroread) into the dialog box.

If the PDF reader is not in the path and you do not know where the executable is or 
if it is installed, contact your system administrator for more information.

To change the file location:

1. From the Help menu, choose Change pdf Reader.

2. In the Help Viewer Chooser, specify the full path to a PDF reader executable.

1.6  Quitting NaqsView
From the File menu, choose Exit.
If you have changed any settings during the session, the Save Settings dialog box 
provides the option to save the changes. (See also Section 1.4.)
NaqsView Version 2.10
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Chapter 2 Using NaqsView

NaqsView provides tools to view SOH data, and to send commands to NaqsServer for 
mass position and centring, and basic calibration.

2.1  Viewing SOH data
NaqsView provides 6 predefined state-of-health (SOH) viewers, and the option to cre-
ate custom viewers based on any active data bundle type:

Instrument Voltage and Temperature
Environmental State of Health
Satellite Modem State of Health
RM4 Voltage and Temperature
Instrument GPS
Mass Position and Centering
Custom

Each SOH viewer provides a tabular view of selected SOH information, and command 
options along the bottom of the viewer.

2.1.1   Working with SOH viewers

Basic options are the same for both predefined and custom viewers.

2.1.1.1    Open an SOH viewer

You can open predefined viewers, and custom viewers that have already been defined. 
(See Section 2.1.2 on page 10 for information on how to create new custom viewers.)

To open a predefined viewer:

From the View menu, choose the viewer (for example, Instrument Voltage and 
Temperature).

To open an existing custom viewer:

1. From the View menu, choose a custom viewer (for example, Authentication Sta-
tus).

2. Choose Show from the sub-menu.
NaqsView Version 2.10
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2.1.1.2    Select stations to view
1. On the SOH viewer, click Select Stations. This will display a table of available sta-

tions (Figure 2-1).

2. Select some of the stations or all stations:

To select some stations, click the check box to select  each station that you 
wish to have displayed in the viewer. (To remove a station that you do not want 
to display, click the check box to deselect it .)

To select all stations at once, click the Select All button. (After you have 
clicked the Select All button, the label changes to Deselect All. If you click the 
button now, all stations will be deselected.)

3. Click OK to accept the new selections. (To exit from the dialog box without mak-
ing any changes, click Cancel.)

2.1.1.3    View active stations only

You may have many stations selected but wish to view only the active stations—those 
that are transmitting data. (Some stations may be relatively inactive—either not trans-
mitting data, or transmitting data at long intervals. An inactive station row has a Last 
Update time of zero (1970-01-01 00:00:00).)

Click the Show Active Only checkbox (Figure 2-2).
This will remove inactive station rows from the display. If a station becomes 
active, the row will be added to the display automatically.

Figure 2-1  Station selector window
NaqsView Version 2.10
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2.1.1.4    Sort data

You can sort the data in a table using the values in any column:

To sort on a given column, click on the column title header. To sort in the opposite 
order, click again on the same column header.

To restore to the default sort order, click the first column header.

2.1.1.5    Customise viewer and column names in predefined viewers

For the predefined SOH viewers, you can customise table and column names by editing 
the NaqsView.properties file in the working directory. You can restore all 
edited values to the default values stored in the original NaqsView.properties 
file. The NaqsView.properties is a text file. Any line beginning with the symbol 
# is read as a comment. The format of each line is MachineCode = LabelString

Note The working directory must contain a NaqsView.properties file in 
order for you to use customised properties. (You can copy this file from 
the user directory, or start NaqsView in the working directory and then 
choose File > Restore Default Properties to create the initial copy.)

2.1.1.5.1    Customise a value

1. In the working directory, open the file NaqsView.properties.

2. Edit the label string. Do not edit the machine code. For example:
• To change the name of the time column of all the viewers from Last Update to 

Time, change the line:
lastupdate.name = Last Update

to:
lastupdate.name = Time

• To change the name of the Voltage column of the Instrument Voltage and Tem-
perature viewer to Battery Voltage, change the line:
ivat.voltage.name = Voltage

to:

Figure 2-2  A predefined SOH viewer (Instrument Voltage and Temperature)
NaqsView Version 2.10
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ivat.voltage.name = Battery Voltage

3. Save the edited NaqsView.properties file.

4. Apply the changes to the viewer(s): In the NaqsView File menu, choose Reload 
Properties.

2.1.1.5.2    Restore to the default values

To overwrite all customised table and column names with the default values from the 
original NaqsView.properties file, and apply these changes to the viewer(s):

In the NaqsView File menu, choose Restore Default Properties.

2.1.2   Working with custom SOH viewers

For any active data bundle (for example, Authentication Status), you can create a cus-
tom SOH viewer to monitor data.

A bundle is active if NaqsView has received a packet containing the bundle during this 
session, or if the bundle was in the buffer when NaqsView was started. Shortly after 
starting NaqsView there may be only a few bundles available, but more will be avail-
able later, depending on the SOH reporting intervals. If no bundles are available, check 
whether you are connected to a valid, running NaqsServer.

The general features of a custom viewer—such as opening an existing viewer, 
table formats, and data sorting options—are the same as for predefined SOH view-
ers. See Section 2.1.1.
All rows in a custom viewer have a Station, Instrument, and Last Update column. 
The remaining data columns are defined by the bundle type. The columns available 
will be the same as those in the .csv file created when SOH data are extracted 
using SohReader or Sohextrp. See the documentation for Playback, State-of-
Health Files Description. (Playback is a set of Nanometrics utilities installed with 
your NaqsServer.)
The threshold values for custom viewers initially use a default set (either the 
generic set 0, 10, 20, 30, or for some bundles a set more specific to the typical val-
ues for the bundle type). See Section 2.1.3 on page 11 for information on visual 
indicators of the SOH status, and Section 2.1.3.4 on page 13 for information on 
editing the threshold values.
The SOH pop-up menu options—Reset, History, and Report—are the same as for 
predefined viewers. See Section A.3 on page 29.

2.1.2.1    Create a custom viewer
1. In the View menu, choose Custom.

Note NaqsView will wait up to 10 seconds for the first data bundles to arrive. If 
no bundles arrive in that time, NaqsView displays a message that no bun-
dles are active. If this happens, check whether you are connected to a 
valid, running NaqsServer.

2. In the dialog box for currently active bundles (Figure 2-3), choose the data bundle 
of interest from the drop-down list. To add all possible bundles to the list of 
NaqsView Version 2.10
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options, select Allow All Bundles (for example, when plotting SOH ringbuffer 
data from inactive stations).
The names of the bundles are the same as described in the documentation for Play-
back, State-of-Health Files Description.

3. Click to select  or deselect  columns to display, and then click OK. (To exit 
without creating the custom viewer, click Cancel.)

2.1.2.2    Select data columns to view

For any existing custom viewer, you can change which data columns are displayed.

1. Open the dialog box for the selected data bundle in either of two ways:

In the custom viewer, click the Edit button.

In the NaqsView window, choose View > data bundle > Edit.

2. In the dialog box for the currently active bundle, click to select  or deselect  
data columns to display.

3. Click Ok to apply the settings. (To discard the changes, click Cancel.)

2.1.2.3    Close a custom viewer
In the View menu, choose the viewer of interest, then choose Hide from the sub-
menu.
The viewer is still available in the main View menu.

2.1.2.4    Delete a custom viewer
In the View menu, choose the viewer name, then choose Delete from the sub-
menu.

2.1.3   Monitoring SOH status in the current session

NaqsView stores the minimum and maximum values for each parameter. It latches 
these values to the last reported minimum or maximum since NaqsView was started. 

Figure 2-3  A custom viewer configuration
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You can view the minimum and maximum values, and you can reset these to the current 
value. You can edit the thresholds for colour-coding of the current status.

2.1.3.1    About SOH visual cues

For some parameters, NaqsView provides visual indicators of the current status (as col-
our-coding of parameter cells), and historical information (arrow symbols to show 
whether parameter values have exceeded the defined range during the current session):

Some columns use colour codes to provide a qualitative grading of the value for 
each station listed in the viewer, using this convention:
• Green – The value is within the acceptable range.
• Yellow – The value is marginal and should be monitored closely.
• Red – The value is out of range, indicating a possible problem.
The thresholds for the Last Update column are not editable. The colour of the Last 
Update cell depends on the difference between time stamp of the arriving bundle 
and the system time, using this convention:
• Green – The time stamp is between 10 seconds ahead and 2 minutes behind the 

system time.
• Yellow – The time stamp is either more than 10 seconds ahead of system time, 

or more than 2 minutes behind system time.
• Red – The time stamp is either more than 30 seconds ahead of system time, or 

more than 5 minutes behind system time.
For parameters that have editable thresholds, an arrow symbol may be displayed 
within the cell to indicate historical information about the parameter values during 
the current session. Display of the arrow is based on the minimum and maximum 
values stored since NaqsView was started:
• An up-arrow  indicates that the value in the cell has breached the upper 

thresholds.
• A down-arrow  indicates that the value in the cell has breached the lower 

thresholds.
• The arrow will be yellow if the Marginal threshold was breached and red if an 

out-of-range threshold (either Low or High) was breached.
Arrow symbols are not shown for:
• Values in the Last Update column.
• These SOH status conditions:

The current status is equal to the stored value for a breached threshold 
(either minimum or maximum).
Minimum and maximum values are within the acceptable range.

2.1.3.2    View the minimum and maximum SOH values
Right click on the parameter cell and choose Report from the pop-up menu.
A report window will display the current, minimum, and maximum values.
NaqsView Version 2.10
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2.1.3.3    Reset the minimum and maximum SOH values

You can reset parameter minimum and maximum values to the current value:

To reset a single parameter, right click on the parameter cell and choose Reset 
from the pop-up menu.

To reset all values in a row, right click on the station cell and choose Reset from 
the pop-up menu.

To reset all values in a column, right click on the column header cell and choose 
Reset from the pop-up menu.

To reset all the values in a table, click the Reset All button at the bottom of the 
viewer.

2.1.3.4    Set SOH thresholds for colour-coded parameters
1. Click the Column Settings button.

2. In the Set column color thresholds dialog box (Figure 2-4), choose the viewer col-
umn from the drop down list.

3. Edit the threshold display settings as desired, then click OK. (To exit from the dia-
log box without making any changes, click Cancel.)

2.1.4   Plotting SOH history data

Note Plotting SOH history data requires an active DataServer. 

You can create plots of time versus some state of health parameter in the History 
Viewer. You can plot the data for a station, a data column, and a data cell. Plots that 
have the same vertical axis label can be combined, and multiple plots can be contained 
in one History Viewer. Use either predefined or custom viewers to view data from 
active stations. To view history data from inactive stations, use a custom viewer (Sec-
tion 2.1.4.3).

Each plot is labelled with the station name and the parameter name. For example, 
STN09.SOH BattVoltage (Figure 2-5).

Figure 2-4  Set column thresholds
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The horizontal axis shows day and time (mmdd_hh:mm:ss), and the axis label 
shows the date or date interval.
The vertical axis shows the range for the selected SOH parameter. The label is 
identical to the column header for the same parameter when the bundle is saved to 
a .csv file using SohReader or Sohextrp. For header names, see the documenta-
tion for Playback, State-of-Health Files Description.
History Viewer settings are included in settings files (see Section 1.4, “Saving 
NaqsView settings,” on page 5).
SOH data are created at regular intervals. If the interval of two values to be plotted 
changes, there will be a break in the plot line to indicate missing data.

2.1.4.1    Select the time interval for the plot

The time interval for an SOH history plot may be any time for which there are SOH 
data; it is not limited to the data for the current NaqsView session.

1. Ensure that the system time is accurate on the computer that is running NaqsView. 
NaqsView uses an interval based the system time to access data via DataServer, 
therefore a system time set to a future date will result in no data being found.

2. In the viewer, right click on the data item you wish to plot—a station, a data col-
umn, or a data cell—and then choose History from the pop-up menu.

Note If other History Viewers are currently open, you have the option to select 
one of these viewers as the destination for this data plot. See Section 
2.1.4.9, “Add data to an existing history viewer,” on page 18.

3. In the Set History Time Interval dialog box, select the time interval for the plot 
(Figure 2-6). (For a data cell, the Time Available section shows the extent of avail-
able data for that cell.):

To choose a start date, start time, and duration, select the option From Start 
Time.

Figure 2-5  A history plot window
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To choose the most recent data, select the option Most Recent.

4. Type in the date and time and/or the duration (these values will update each other 
as appropriate). 

5. From the drop-down list, choose units for the duration (seconds, minutes, hours, or 
days).

6. Click Ok to generate the history plot. (To exit without generating a plot, click Can-
cel.)

2.1.4.2    Select data to view
In general, right click on a cell to select data to view. Note these options and condi-
tions:

These conditions apply to both predefined and custom viewers:

Ensure that the system time is accurate on the computer that is running NaqsView. 
NaqsView uses an interval based the system time to access data via DataServer, 
therefore a system time set to a future date will result in no data being found.
If a row in a viewer has not received any SOH data during the current session, the 
Last Update column will show January 1, 1970.

These options and conditions apply to predefined viewers only:
Options for viewing data for a cell depend on whether there is one or more than 
one bundle types underlying the cell.

If there is only one underlying bundle type for a cell, choose the relevant data:

Right click on the cell, and then use the dialog box to choose a data item 
from the bundle.

If there is more than one bundle type underlying a cell, choose the relevant 
data:
i. Right click on the cell. This will open a pop-up menu listing the relevant 

bundle types.
ii. Choose a bundle type from the pop-up menu. This will open a dialog box 

listing the relevant data items.
iii. From the dialog box, choose a data item from the bundle and click OK. 

This data item is now the data value that will be plotted if you right click on 
the cell again. At that time, the menu will now be that of an ordinary cell.

Figure 2-6  Choose the time interval of SOH data to plot
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There is no attempt to check that the correct value for that cell was chosen. 
To correct an error, close and restart NaqsView.

Should an SOH bundle arrive from NaqsServer after the data type is set, it will be 
reset to the bundle and data item.
If you select a History Viewer from a station cell and no bundles have arrived, a 
History Viewer will open but no data will be found unless a cell has had its bundle 
and data type set as described above.
If you select a History Viewer from the column header, a History Viewer will 
open. If any cell is undefined, no data will be found unless the cell has had its bun-
dle and data type set as described above.

2.1.4.3    View SOH data from inactive stations

To view ringbuffer SOH data from inactive stations:

1. Add the relevant channel information to the Naqs.stn file if it is not already in 
the file. (Note that the added station should have a unique name.)

2. Restart NaqsServer and DataServer.

3. Start NaqsView if it is not already running.

4. In the View menu, choose Custom.

5. If the bundle type of interest is not in the drop down list, select the Show All Bun-
dles check box (Figure 2-2 on page 9).

6. Select the bundle of interest.

7. Select data to view in a History Viewer (see Section 2.1.4.2).

2.1.4.4    Plot first differences

First differences of the data are each value minus the previous value. Accumulated data 
such as serial port packet counts are often best viewed as first differences. When a first 
difference plot is created, it is indicated on the x-axis label that it is a first difference 
plot.

To plot first differences, select the Plot First Difference checkbox .

To view unprocessed data, deselect the Plot First Difference checkbox .

2.1.4.5    Combine and separate plots

You can combine plots that have the same vertical axis label, combine all plots into a 
single plot with a legend, and separate combined plots into single plots:

To combine plots that have the same vertical axis label, either click the Combine 
Plots button or pull down the plot View Menu and choose Combine Plots.
The colour of the station name in the top label will change to correspond to the 
colour of the plot as well as put data with the same label on the plot. The option 
button is now Single Plots (Figure 2-7).
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To combine all plots into a single plot with a legend, in the View menu choose 
Combine All Plots (Figure 2-8).
This feature is not saved in plot settings.

To separate a combined plot into single plots, click the Single Plots button.

2.1.4.6    Change the history viewer window layout

Window layout options are a scrolling window (the default layout), and all plots dis-
played in the visible area of the window:

To fit all the plots in the visible area of the window, click the Fit To Window but-
ton.
The plots will be squeezed into the window without a scroll bar. You may have to 
enlarge the window to see the individual plots. The option button is now Scroll.

To display the plots in a scrolling window, click the Scroll button.

Figure 2-7  History viewer combined plots

Figure 2-8  Single combined plot with a legend
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2.1.4.7    View the plot thresholds

Thresholds defined in the viewers may also be shown on plots. The default is to show 
only the thresholds visible within the data and within the marginal limits. The marginal 
limits will be plotted as green, dashed, horizontal lines. If the data exceed these limits, 
red threshold lines may be visible, indicating data has exceeded the marginal range. 
Plot threshold settings are included in settings files. (See also Section 2.1.3.1, “About 
SOH visual cues,” on page 12, and Section 1.4, “Saving NaqsView settings,” on 
page 5.)

In the plot View menu, choose Show Thresholds, and choose an option:
• Default
• All
• None

2.1.4.8    Change the time interval
1. In the plot Data menu, choose Change Times.

2. In the Set History Time Interval dialog box, select the time interval for the plot 
(Figure 2-6 on page 15):

To choose a start date, start time, and duration, select the option From Start 
Time.

To choose the most recent data, select the option Most Recent.

3. Click OK to update the plots.

2.1.4.9    Add data to an existing history viewer

If a history viewer is open, you have the option to plot additional data in the viewer. 
You can add data through the menu for a station, an individual parameter, or a column. 
For individual and station data, you can drag the cell and drop it in an existing history 
viewer. This drag and drop feature is not available for the column header cell.

Note If you are using a Java version earlier than version 1.4.1_04, do not drop 
a cell into a history viewer from another NaqsView. The action will crash 
the NaqsView receiving the drop.

To add all data for a station, or data for an individual parameter, either:

Drag and drop the station or parameter cell onto the history viewer.

Right click on the data cell or station cell and choose the existing viewer you 
wish to add the data to (Figure 2-9).

To add column data, right click on the column header and choose the existing 
viewer you wish to add the data to (Figure 2-9).
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2.1.4.10    Edit plot characteristics

You can edit plot characteristics during the current session—such as axis labels, range, 
and tick marks—using options in the plotting library that is used by NaqsView. No 
other documentation is available for the plotting library, but with some experimenta-
tion, you can see how the features can be used to change the appearance of a plot.

The plot editor will apply only to the selected plot. Changes made to the plot in this 
manner will not be saved.

Shift-click on the plot to open the plot editor.

2.1.4.11    Print plots

You can print a selected plot, and all plots in a history viewer:

To print a selected plot, right click on the plot of interest and choose Print Plot.
The plot will be printed in portrait format on a half page.

To print all the plots, in the File menu choose Print All Plots.
If the history viewer is set to Scroll, there will be a single plot on each half page. If 
the viewer is set to Fit To Window, all the plots will be squeezed onto a single 
page.

2.1.4.12    Save data

You can save the underlying bundle data of a plot, and save all the data for all the plots:

To save the underlying bundle data of a plot, right click on the plot and choose 
Save Data. In the Save dialog box, choose the destination directory for the data.
The entire bundle is saved to a .csv file of the same format as that saved using 
SohReader or Sohextrp.

To save all the data for all the plots, in the plot File menu, choose Save All Data.
All the bundles underlying all the plots in the viewer will be saved in .csv for-
mat.

2.1.4.13    Delete a plot
1. In the Data menu, choose Delete Plots.

2. From the list of available plots, choose the plot to delete. There will be no warning 
dialog.

To recreate a deleted plot, find the cell of interest and drag it to the history viewer, 
or right click on the cell and choose an existing history viewer.

Figure 2-9  Add data to an existing viewer through the menu
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2.2  Calibrating sensor channels
Note Some sensors do not support calibration; NaqsView will not allow you to 

select channels that cannot be calibrated.
Some sensors do not permit individual channels to be calibrated, so 
selecting one channel may force other channels on the same digitiser to 
be selected as well. In this case, NaqsView will prompt you to accept the 
implicit selections.

NaqsView provides a basic calibration utility. For additional calibration options, use 
Nanometrics Calibrate.

The Sensor Calibration viewer shows a tabular display of seismic channels, with infor-
mation about the sensor for each channel. You can sort the table and select which chan-
nels to display as for any SOH viewer (see Section 2.1 on page 7).

Nanometrics digitisers (Trident and HRD-24) perform calibration by sending a signal 
to the sensor. NaqsView allows you to set the frequency, amplitude, and duration of the 
sine wave calibration signal.

The calibration DAC on Nanometrics digitisers can produce a maximum signal ampli-
tude of 5 volts. The corresponding maximum signal amplitude (in micrometres per sec-
ond) is computed for each selected channel and displayed in the last column of the 
table. If you specify a calibration amplitude greater than the maximum, the amplitude 
will be reset to the maximum.

2.2.1   Calibrate one or more sensor channels
1. Choose Sensor Calibration from the View menu to open the viewer.

2. Click on the appropriate checkbox in the Selected column of the table to select a 
channel to be calibrated . (To remove a channel that you do not want to display, 
click the check box to deselect it ).

3. Set the calibration signal characteristics:
a) Click the Signal Settings button in the Sensor Calibration window.
b) In the Calibration Settings dialog box, edit values for the calibration signal fre-

quency (in hertz), amplitude (in micrometres per second), and duration (in sec-
onds).

c) Click OK to accept the new settings. (To close the dialog without saving the 
changes, click Cancel.)

The signal characteristics are shown at the bottom of the Sensor Calibration win-
dow.

4. Send the calibration command to NaqsServer: Click the Calibrate button.
NaqsView will prompt you for a calibration password, send the command to 
NaqsServer, and report the result. For security reasons you must enter the pass-
word each time you send a calibration command.

Optionally, to view the calibration result online, run Waveform side-by-side with 
NaqsView.
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2.3  Mass centring
Note Some sensors do not support mass centring; NaqsView will only allow 

you to select digitisers that have at least one channel that supports mass 
centring. Stations that have not received the FastExternalSohBundle will 
not be selectable.

The Mass Position and Centering viewer shows a tabular display of digitisers with real-
time mass position SOH information, and the sensor type and number of channels sup-
porting mass centring on each digitiser. The Mass Centering viewer shows all stations 
from NaqsServer. You can sort the table, select stations, and set colour-coding thresh-
olds for the SOH columns as for any SOH viewer (see Section 2.1 on page 7).

2.3.1   Centre the mass on one or more sensors
1. From the View menu, choose Mass Position and Centering.

2. Click on the appropriate checkbox in the Selected column of the table to select one 
or more channels to centre.
This actually selects digitisers; all channels on each selected digitiser are centred 
simultaneously.

3. Click the Mass Center button to send the mass centre command to NaqsServer.
NaqsView will prompt you for a password, send the command to NaqsServer, and 
report the result. For security reasons you must enter the password each time you 
send a mass centring command.
A few minutes after sending the mass centre command, you should see a change in 
the mass position for the selected digitisers. The exact delay will depend on the 
sensor type and on the configured SOH reporting frequency for the digitiser.
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Appendix A UI Main Elements

This section provides an overview of the NaqsView user interface main elements—the 
options available from the main menus, overviews of the SOH viewers, and overviews 
of the SOH pop-up menus.

A.1  NaqsView main menus
NaqsView has four main menus—File, View, Log, and Help (Figure 1-1 on page 4).

A.1.1   File

The File menu provides file management options, listed in Table A-1.

A.1.2   View

Each item in the View menu opens a separate viewer window showing selected state-
of-health information, or providing controls for mass centring. These viewers are pro-
vided:

Instrument Voltage and Temperature
Environmental State of Health
Satellite Modem State of Health

Table A-1  File menu options

Option Description

Open Load a NaqsView settings file from disk, selectable from a 
browser window.

Save Save the current NaqsView settings using the current file 
name.

Save As Save the current NaqsView settings to a new file name.

Restore Default Properties Restore the default viewer and column names by overwriting 
the NaqsView.properties file in the current working directory 
with the original NaqsView.properties file.

Reload Properties Apply the viewer and column name definitions from the 
NaqsView.properties file in the current working directory.

Exit Exit from the NaqsView program.
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RM4 Voltage and Temperature
Instrument GPS
Mass Position and Centering
Custom

See Section A.2, “SOH viewers,” on page 24 for a summary of the options in each of 
these windows.

A.1.3   Log

The Log menu provides options for controlling the log that is displayed in the Naqs-
View log window. Log menu options are listed in Table A-2.

A.1.4   Help

The Help menu provides the options listed in Table A-3. See also Section 1.5, “Open-
ing the Help file,” on page 5.

A.2  SOH viewers
This section lists the controls and displayed variables for each of the SOH viewer win-
dows. All predefined viewer windows except Mass Position and Centering have the set 
of controls as described in Table A-4.

Table A-2  Log menu options

Option Description

Debug Set the log verbosity to display all messages.

Verbose Set the log verbosity to display additional (less important) messages than would 
be displayed with the Info setting.

Info Set the log verbosity to display significant messages.

Clear Log Clear all log messages from the display.

Show Log View the log in a separate window.

Table A-3  Help menu options

Option Description

Help topics View a PDF copy of the user guide.

Change pdf Reader Define a different location for a PDF executable.

About NaqsView View the current NaqsView version information.

Table A-4  SOH viewer basic controls

Control Description

Show Active Only • Check box.
• Select to show only the stations for which NaqsView is receiving bun-

dles.
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A.2.1   Instrument Voltage and Temperature

The Instrument Voltage and Temperature window shows battery voltage and tempera-
ture readings for selected 12V instruments, including digitisers and Libra transceivers. 
(See Table A-4 for basic controls and Table A-5 for column definitions.)

A.2.2   Environmental State of Health

The Environmental State of Health window shows the external state of health readings 
for selected instruments. The units and scaling for these channels are user-defined in 
the configuration for the corresponding instrument. Each channel may be scaled sepa-
rately. See Table A-6 for column definitions, and Table A-4 on page 24 for basic con-
trols.

Reset All • Control button.
• Reset the minimum and maximum values for all cells in the table.

Select Stations • Control button.
• Select which stations to display in the table.

Column Settings • Control button.
• Set colour-coding thresholds for each column.

Table A-4  SOH viewer basic controls (Continued)

Control Description

Table A-5  Instrument Voltage and Temperature column definitions

Column Definition

Station The station name for this instrument.

Instrument The instrument type and serial number.

Last Update The time of the last SOH update for this instrument.

Voltage The supply voltage to this instrument.

Temperature The internal temperature of the instrument in degrees Celsius.

Table A-6  Environmental State of Health column definitions

Column Definition

Station The station name for this instrument.

Instrument The instrument type and serial number.

Last Update The time of the last SOH update for this instrument.

Channel 1 The scaled SOH reading for channel 1.

Channel 2 The scaled SOH reading for channel 2.

Channel 3 The scaled SOH reading for channel 3.
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A.2.3   Satellite Modem State of Health

The Satellite Modem State of Health window shows the internal state of health for 
selected Libra transceivers. See Table A-7 for column definitions, and Table A-4 on 
page 24 for basic controls.

A.2.4   RM4 Voltage and Temperature

The RM4 Voltage and Temperature window shows battery voltage and temperature 
readings for selected RM4s. RM4s use a 5V power supply. See Table A-8 for column 
definitions, and Table A-4 on page 24 for basic controls.

A.2.5   Instrument GPS

The Instrument GPS window shows the status of the timing system for the selected 
instrument. (Some instruments—such as the Janus Communications Controller, Cyg-
nus with NMXbus, and EuropaT—use a TimeServer, essentially a GPS-disciplined 
clock that can also provide backup timing, while instruments such as the Carina Trans-
ceiver and the HRD use GPS timing directly.) The data shown will depend on the tim-
ing system used for the selected instrument.

The type of GPS engine used—Trimble or Rockwell—depends on the instrument. 
Fields which are not computed for a specific GPS type are left blank.

Each line may contain data from more than one bundle type, so some of the data in a 
line may be older than other data. The older data will be greyed out.

Table A-7  Satellite Modem State of Health column definitions

Column Definition

Station The station name for this instrument.

Instrument The instrument type and serial number.

Last Update The time of the last SOH update for this instrument.

Voltage The supply voltage to the instrument.

Controller Temp The Comms Controller board temperature in degrees Celsius.

SSPB Temp The SSPB temperature in degrees Celsius.

Modem Temp The satellite modem temperature in degrees Celsius.

10MHz Freq Err The frequency error of the 10MHz clock in hertz.

Table A-8  RM4 Voltage and Temperature column definitions

Column Definition

Station The station name for this instrument.

Instrument The instrument type and serial number.

Last Update The time of the last SOH update for this instrument.

Voltage The supply voltage to this instrument.

Temperature The internal temperature of the instrument in degrees Celsius.
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See Table A-9 for column definitions, and Table A-4 on page 24 for basic controls.

Table A-9  Instrument GPS column definitions

Column Definition

Station The station name for this instrument.

Instrument The instrument type and serial number.

Last Update The time of the last SOH update for this instrument.

Clock State
 

The state of the instrument internal clock:

Fine lock The clock is phase-locked and within 20µs of GPS (or 
TimeServer) time.

Coarse lock The clock is phase-locked to the GPS (or TimeServer).

No lock The clock is free-running with temperature compensation, 
because there is no solution from the GPS.

GPS State
 

(Trimble GPS engine, used by Libra transceivers, Europa-IP digitisers.)

Doing Fixes The GPS is navigating and computing time and 3D 
position .

No time The GPS is not computing the time (for example, if no 
satellites are available).

Needs init The GPS needs to be initialized.

PDOP too high* The GPS is not computing the time because PDOP is too 
high.

Acquiring The GPS is tracking fewer than 4 satellites.

GPS State (Rockwell GPS engine, used by HRDs and non-IP Europa digitisers.)

3D Nav The GPS is navigating and computing time and 3D 
position.

2D Nav The GPS is navigating and computing time and 2D 
position.

Tracking The GPS is unlocked but tracking one or more satellites.

Searching The GPS is unlocked and searching for satellites.

GPS Off The GPS is powered off.

Error The GPS is in an error state.

Time Err (ns) The worst estimate of the clock error in nanoseconds.

# Satellites The number of usable satellites being tracked by the GPS 
engine.

PDOP*

* PDOP and TDOP are standard estimates of the GPS solution error, with lower values 
indicating a better solution. The GPS engine will not generate a solution if the PDOP is 
too high.

The position dilution-of-precision.

TDOP* The time dilution-of-precision.

Max S/N ratio The maximum signal to noise ratio (dB) for any satellite.
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A.2.6   Mass Position and Centering

The Mass Position and Centering window shows mass position for all stations form 
NaqsServer, and provides options to centre the mass on sensors that support mass cen-
tring. Stations that have not received the FastExternalSohBundle will not be selectable. 
See Table A-10 for column definitions and Table A-11 for basic controls.

A.2.7   Custom

The column definitions for a custom viewer are defined by the selected data bundle 
type. (For descriptions of the data bundles, see the documentation for Playback, State-
of-Health Files Description.) Each custom viewer also has the View sub-menu options 
described in Table A-12, and the basic controls described in Table A-13.

Table A-10  Mass Position and Centering column definitions

Column Definition

Station The station name for this instrument.

Selected Indicates if this instrument is selected for mass centring.

Instrument The instrument type and serial number.

Last Update The Ttime of the last SOH update for this instrument.

Mass Pos 1 Channel 1 mass position.*

* In units as configured on the digitiser—voltage (active high or active low), or current

Mass Pos 2 Channel 2 mass position.*

Mass Pos 3 Channel 3 mass position.*

Sensor Type The primary sensor type connected to this digitiser.

Channels The number of channels which support mass centring on this instrument .

Table A-11  Mass Position and Centering controls

Control Description

Show Active Only • Check box.
• Select to show only the stations for which NaqsView is receiving bun-

dles.

Select Stations • Control button.
• Select which stations to display in the table.

Column Settings • Control button.
• Set colour-coding thresholds for each column.

Mass Center • Control button.
• Send a mass-centring command to NaqsServer.

Table A-12  Custom viewer sub-menu options

Option Description

Show Open an existing custom viewer on the desktop.

Hide Hide an existing custom viewer that is open on the desktop.
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A.3  SOH pop-up menus
Individual data cells, data column headers, and station cells present right click pop-up 
menus (Figure A-1).

The individual data cell menu has the options Reset, History, and Report. The 
selection applies to the individual cell.
The data column header menu has the options Reset and History. The selection 
applies to all the cells in the column.
The station menu has the options Reset and History. The selection applies to all the 
cells in the row.

Edit Select which data columns to display in the custom viewer.

Delete Delete the custom viewer from NaqsView.

Table A-13  Custom controls

Control Description

Show Active Only • Check box.
• Select to show only the stations for which NaqsView is receiving bun-

dles.

Reset All • Control button.
• Reset the minimum and maximum values for all cells in the table.

Select Stations • Control button.
• Select which stations to display in the table.

Column Settings • Control button.
• Set colour-coding thresholds for each column.

Edit Columns • Control button.
• Choose columns to show from those available for this bundle type in 

this viewer.

Table A-12  Custom viewer sub-menu options

Option Description

Figure A-1  An SOH viewer showing all pop-up menus
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A.4  History viewer menus
The History Viewer has three main menus—File, View, and Data (Figure 2-7 on 
page 17).

A.4.1   File

The File menu provides history plot file management options, listed in Table A-15.

A.4.2   View

The View menu provides history plot display management options, listed in Table A-
16. (Additional display options applicable only during the current session are available 
from the pop-up plot library: Shift-click on the data plot to open the library.)

A.4.3   Data

The Data menu provides history plot data management options, listed in Table A-17.

Table A-14  SOH pop-up menu options

Option Description

Reset Reset the minimum and maximum values to the current value:
• A pop-up menu option for an individual data cell, all values in a column, all val-

ues in a station row.
• A command button option for all values in a table.

History Set the time interval to plot SOH history, in a new or an existing history viewer.

Report View a report window showing the current value, and the minimum and maximum 
values reached during the current NaqsView session.

Table A-15  History Viewer File menu options

Option Description

Save All Data Save all plotted data to individual files in a directory selectable from the 
Save To dialog box (defaults to the current working directory).

Print All Plots Open a print window and select options to print all plots.

Exit Exit from the History Viewer.

Table A-16  History Viewer View menu options

Option Description

Single Plots Split combined plots out into individual plots.

Combine Plots Combine individual plots with the same vertical axis into a single plot.

Combine All Plots Combine all individual plots into a single plot with a legend.

Show Thresholds Show thresholds as horizontal lines on the plot. Options are Default, All, 
None.
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Table A-17  History Viewer Data menu options

Option Description

Change Times Edit the start and end times, and duration, of the data to plot.

Delete Plots Delete selected or all plots. Options are
• For a viewer showing single plots or combined plots, select from the plot 

list.
• For a viewer showing all combined plots, select the option delete all 

plots.
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