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Waveform Viewer

1  About Waveform Viewer
Waveform Viewer (Waveform) provides a simple, intuitive interface to view realtime 
time-series waveforms from NaqsServer. It can display an unlimited number of traces 
in one window. All the traces are plotted using the same time scale, but each trace can 
be scaled individually on the vertical axis.

Waveform allows you to subscribe to any time-series channels from NaqsServer. For 
each subscribed channel, Waveform displays a trace plus some computed signal statis-
tics—maximum, minimum, mean, and RMS (for example, see Figure 3-1 on page 3). 
These statistics apply to the time-series values that are currently displayed in the trace 
window.

Waveform communicates with NaqsServer via TCP/IP socket, so it can be run either 
on the NaqsServer machine, or on any other machine that has an Internet connection to 
NaqsServer.

2  Installing Waveform
Waveform is part of the Naqs Client package, included on the Nanometrics software 
installation CD.

2.1   Install Waveform

On Windows:

1. If the directories c:\nmx\bin and c:\nmx\user do not already exist on the 
computer, create them.

2. From either a command prompt or Windows Explorer, open the installation CD 
directory Win32\Waveform\version number.

3. Copy all files from the bin directory into the c:\nmx\bin directory, and all 
files from the user directory into the c:\nmx\user directory.

4. Check the system path, and add the directory c:\nmx\bin if it is not already 
included.

5. Optionally, create a shortcut (Section 2.2).
Waveform Viewer Version 2.00
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Waveform Viewer
On Solaris or Linux:

See the acquisition workstation installation instructions.

2.2   Create a shortcut

The optional parameter settingsFile specifies a settings file to load on startup (see also 
Section 4, “Saving Waveform settings,” on page 3).

On Windows:

1. Create a shortcut on the desktop to the file waveform.bat.

2. Right click on the shortcut icon and choose Edit.

3. Edit the startup parameters to use a specific settings file rather than the default:
javaw -cp c:\nmx\bin\waveform.jar WaveformApp settingsFile

On Solaris or Linux:

See the acquisition workstation installation instructions.

3  Starting Waveform
Waveform runs in the Java runtime environment version 1.4 or later.

You can start a Waveform session from a shortcut or from the command line.

3.1   Start Waveform
Start Waveform with the desktop shortcut, if you have defined one.

If you are not using a shortcut:

1. Open a command prompt.

2. Change directories to your working directory. Unless you have defined a different 
working directory, this will be nmx\user.

3. Start Waveform from the command line:
Waveform settingsFile
where the optional parameter settingsFile specifies a settings file to load on startup 
(see also Section 4, “Saving Waveform settings,” on page 3). If no settings file is 
specified, it will load settings from the file waveform.ini in the current work-
ing directory.

3.2   Connect to NaqsServer
1. In the Connection control bar fields at the bottom of the Waveform main window 

(Figure 3-1), type the host name or IP address, and the port of the NaqsServer 
Datastream service.
If you specified a settings file on startup, Waveform will connect automatically to 
the host address and port specified in the file.
Waveform Viewer Version 2.00
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Waveform Viewer
2. If the NaqsServer Datastream service has been configured to operate in callback 
mode, click to select the callback socket check box .

3. Click the connect checkbox.
The connection status will be displayed at the right of the Connection control bar.

4  Saving Waveform settings
You can save all Waveform settings—such as connection parameters, channel selec-
tion and scaling, and the size and placement of windows—to a settings file. You can 
save these settings at any time during a Waveform session either to a new settings file, 
or to the current settings file if you want to replace the current settings. Any changes to 
the settings (for example, unsubscribing a channel) will be saved automatically when 
you exit Waveform.

You can start new Waveform sessions with saved settings, or load different settings 
during a running session of Waveform.

Note The settings file is a binary format and cannot be edited manually.

4.1   Save Waveform settings to a settings file

To save a new settings file:

1. From the File menu, choose Save As....

2. In the browser window, select the path and type in a file name.

3. Click Save. (To exit without saving the changes, click Cancel.)

To overwrite settings in the current settings file with the new settings:

From the File menu, select Save.

Figure 3-1  Waveform main window

Scale control bar

Connection control bar
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Waveform Viewer
4.2   Load saved settings

Waveform will automatically connect to NaqsServer and restore all window sizes and 
settings when it loads a settings file. There are two ways to restore Waveform settings 
that you have saved:

Specify the name of the settings file when you start Waveform, either predefined 
as part of the shortcut target or as a command-line argument:
Waveform settingsFile

Load the settings using the Load Settings option of the Waveform File menu:
File > Load Settings ... > filename

5  Quitting Waveform
From the File menu, choose Exit.
If you have changed any settings during the session, the new settings will be saved 
automatically to the current settings file.

6  Using Waveform
You can use Waveform to view data trace for any available channel, and use Waveform 
options to manipulate the views of traces. You may add data channels to the view (sub-
scribe) or remove channels (unsubscribe) at any time.

6.1   View waveform traces for a channel
1. From the Trace menu, choose Subscribe.

2. In the Select Channels dialog box, click the check box to select each channel that 
you want to view.

3. Click OK to add the selected channels to the view. (To discard your changes, click 
Cancel). 

6.2   Remove traces from the view

You can remove individual traces from the view, and remove all traces from the view 
at once:

To remove an individual trace, right click on the trace and choose Unsubscribe in 
the pop-up dialog box (Figure 6-1).

To remove all traces from the view, in the Trace menu, choose Unsubscribe All.
Waveform Viewer Version 2.00
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Waveform Viewer
6.3   Scale all traces

All traces have the same time scale, and by default, all use the same vertical scale. You 
can change the time scale and the vertical scale for all traces at once:

Use the options in the Scale control bar (Figure 3-1 on page 3) to set the time 
width and the vertical scale.
• You may specify a vertical scale, or select the Auto check box to use automatic 

scaling.

6.4   Scale individual traces

To specify a different vertical scale for an individual trace:

1. Right click on the trace to display the pop-up trace dialog box (Figure 6-1).

2. Deselect the default scale checkbox .

3. In the Scale field at the top of the pop-up dialog box, type in the trace-specific 
scale.

6.5   Centre the plot on the trace DC value

Centring a plot around the DC value of the trace is useful for channels with a large DC 
offset. You can centre an individual plot, or centre all plots at once:

To centre an individual plot, right click on the trace to open the pop-up dialog box, 
and then select track DC. 

To centre all plots, in the Scale control bar, select track DC. (Individual traces must 
have default scale selected.)

6.6   Synchronize traces

You can specify whether the time scales of all traces are synchronized. To synchronize 
traces:

In the Scale control bar, select the synchronize traces checkbox (Figure 3-1 on 
page 3).

Figure 6-1  Unsubscribe a trace with the trace pop-up dialog box
Waveform Viewer Version 2.00
User Guide
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6.7   Reset traces

You can clear all traces and set the start time to zero.

In the Trace menu, select Reset.

6.8   Freeze the display
In the Scale control bar, select the freeze checkbox to freeze the display. Deselect 

 freeze to resume updating the trace with current data (Figure 3-1 on page 3).

6.9   View data point information

You can view the time and sample value for any point on a trace:

Hold the mouse pointer steady on a trace for a few seconds to view information for 
the data point under the mouse pointer (Figure 6-2).

7  Waveform menus and controls
This section provides a summary of the Waveform menu options and window controls.

7.1   Waveform menus

Waveform has three main menus—File, Trace, and Help.

7.1.1    File

The File menu provides file management options, listed in Table 7-1.

Figure 6-2  View data point information

Table 7-1  File menu options

Option Description

Load Settings Load a Waveform settings file from disk, selectable from a browser window.

Save Settings Save the current Waveform settings using the current file name.

Save As Save the current Waveform settings to a new file name.

Exit Exit from the Waveform program.
Waveform Viewer Version 2.00
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7.1.2    Trace

The Trace menu provides options to add and remove time series channels from the dis-
play, as listed in Table 7-2.

7.1.3    Help

The Help menu provides the options listed in Table 7-3.

7.2   Waveform controls

The main Waveform window has two main control bars—the Connection control bar, 
at the bottom of the window, and the Scale control bar, at the top of the window (Figure 
3-1 on page 3). You can open a trace dialog box by right clicking on a trace (Figure 6-
1 on page 5).

7.2.1    Connection control bar

The Connection control bar provides controls for specifying the NaqsServer address 
and connection parameters, as described in Table 7-4.

Table 7-2  Trace menu options

Option Description

Subscribe View the Select Channels dialog box, which provides the option for you to 
select which channels to display.

Unsubscribe All Remove all traces from the display.

Reset Clear the traces from the plot and set the start time to zero. 

Table 7-3  Help menu options

Option Description

Help Topics View a PDF copy of the user guide.

About Waveform View the current Waveform version information.

Table 7-4  Connection controls

Control Description

host • Text field.
• Specify the host name or IP address of the NaqsServer host.

port • Text field.
• Specify the TCP port used for NaqsServer Datastream service.

callback • Check box.
• Select if Waveform should connect using a callback socket.

connect • Check box.
• Select to apply the connection parameters and connect to NaqsServer.
Waveform Viewer Version 2.00
User Guide
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7.2.2    Scale control bar

The Scale control bar provides scaling controls for all traces, as described in Table 7-
5. The scales defined here are default scales for all traces, which may be overridden for 
each trace using the trace pop-up dialog box (Section 7.2.3).

7.2.3    Trace pop-up dialog box

The trace pop-up dialog box provides scaling controls for a specific trace, as described 
in Table 7-6. Right click on a trace to open this dialog box.

Table 7-5  Trace scale controls

Control Description

time width (sec) • Text field.
• Specify the time width of the traces in seconds.

synchronize • Check box.
• Select to synchronize time scales for all traces.

freeze • Check box.
• Freeze the view of the traces (that is, stop updating traces with new 

data).

vertical scale • Text field.
• Specify the vertical scale of the trace plots in counts.

track DC • Check box.
• Select to centre each trace about the DC value of its trace (useful for 

channels with a large DC offset).

auto • Check box.
• Select to use automatic scaling for all traces. Selecting this box disables 

the vertical scale field.

Table 7-6  Trace pop-up dialog box controls

Control Description

Scale • Text field.
• Specify the vertical scale for this trace.

default scale • Check box.
• Select to set this trace to use the default scale.

auto scale • Check box.
• Select to set this trace to use automatic scaling.

track DC • Check box.
• Select to centre this plot at the DC value of the trace.

Reset • Menu option.
• Clear the trace from the plot and set its start time to zero.

Unsubscribe • Menu option.
• Remove this trace from the display.
Waveform Viewer Version 2.00
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